Download Pseudocódigo y PSEINT PDF

TitlePseudocódigo y PSEINT
LanguageEnglish
File Size739.3 KB
Total Pages41
Table of Contents
                            INTRODUCCIÓN
¿Qué es PSEINT?
El Pseudocódigo
Forma general de un algoritmo en Pseudocódigo
Tipos de datos
Expresiones
Primitivas Secuenciales (Comandos de Entrada, Proceso y Salida)
Estructuras de Control (Proceso)
Ejecución Paso a Paso
Ejemplos de Algoritmos
Ejercicios Resueltos utilizando PSeint
                        
Document Text Contents
Page 1

Pseudocódigo y PSEINT



















Programa Educativo

Ingeniero en Software


Marzo 2016

Page 2

2


INDICE

INTRODUCCIÓN .................................................................................................... 4

¿QUÉ ES PSEINT? ................................................................................................ 5

La interfaz y el área de trabajo ..................................................................... 5

EL PSEUDOCÓDIGO ............................................................................................. 7

FORMA GENERAL DE UN ALGORITMO EN PSEUDOCÓDIGO ......................... 7

TIPOS DE DATOS .................................................................................................. 7
Tipos de Datos Simples .................................................................................. 8
Estructuras de Datos: Arreglos ....................................................................... 8
Dimensionamiento (Arreglos-Arrays) .............................................................. 8

EXPRESIONES ....................................................................................................... 9
Operadores ..................................................................................................... 9
Funciones matemática .................................................................................. 10

PRIMITIVAS SECUENCIALES (COMANDOS DE ENTRADA, PROCESO Y
SALIDA) ................................................................................................................ 11

Lectura o entrada .......................................................................................... 11
Asignación o proceso .................................................................................... 11
Escritura o salida .......................................................................................... 11

ESTRUCTURAS DE CONTROL (PROCESO) ..................................................... 12

Condicionales ............................................................................................. 12
Si-Entonces (If-Then) .................................................................................... 12
Selección Múltiple (Select If) ......................................................................... 12

Repetitivas ................................................................................................... 13
Mientras Hacer (while) .................................................................................. 13
Repetir Hasta Que (do-while) ....................................................................... 14
Para (for) ....................................................................................................... 14

EJECUCIÓN PASO A PASO .............................................................................. 145

EJEMPLOS DE ALGORITMOS .......................................................................... 167

EJERCICIOS RESUELTOS UTILIZANDO PSEINT ........................................... 212

Page 20

20



prom<-acum/n;


Escribir "El promedio es: ",prom;

FinProceso

Page 21

21


Ejercicios Resueltos utilizando PSeint


1. Escribir un nombre y saludar

//Programa para Escribir un saludo con el nombre: RPC


Proceso Escribir_nombre

Escribir "Programa para saludar"; //muestra en pantalla:
"Progr...saludar"

Escribir "Escribe tu nombre"; //instrucción
Leer a; //ingresa por teclado un texto
Escribir "Hola! Tu nombre es: ", " ****", a, "****"; //muestra un saludo
con el nombre escrito

FinProceso //fin del proceso

Page 40

40



//Calculo del promedio de una lista de 'N' números


Proceso Promedio
Escribir "Ingrese la cantidad de datos";
Leer N;
acum<-0;

Para i<-1 Hasta N Hacer

Escribir "Ingrese el dato ",i,":";
Leer dato;
acum<-acum+dato;

FinPara


prom<-acum/N


Escribir "El promedio es: ", prom;

FinProceso

Page 41

41

Similer Documents